Plugin doesn't show under Sierra

Paul Sandwijk's Avatar

Paul Sandwijk

28 Sep, 2017 11:04 AM

I have a problem that sometimes occurs with my clients, but not on my own Mac: the plugin doesn't show under the Preferences > Plugins, even though I copied the newest plugin to the Extensions folder of my runtime application.

Both my clients and I have Mac OS 10.12.6 installed; the runtime version was created with FMPA 15. The plugin does show up on my Mac, but not on the Mac of my client. What's more: the plugin looks different in the Extensions folder. On my Mac it has the appearance of a folder, whereas on the mac of my client is has the appearance of a file (that cannot be linked to a recognizable application).

This problem is driving me nuts, because I don't know when it will appear.
Registration of the plugin is not a solution here, because I want to give my clients a trial version for some time; then they can choose to buy my application with or without the plugin.

Any help is appreciated.

  1. Support Staff 1 Posted by Support on 28 Sep, 2017 11:26 AM

    Support's Avatar

    Hi Paul,

    Did you also copy the plugin to the extensions folder of the runtime solution? The normal FileMaker Plugins don't get loaded when you start the application from a runtime solution.

    Kind regards,
    Jasper

  2. 2 Posted by Paul Sandwijk on 28 Sep, 2017 11:29 AM

    Paul Sandwijk's Avatar

    Hi Jasper,

    Yes, I did (of course).
    Bij de ene klant toont hij wel, bij de andere niet.
    Terwijl de installatie hetzelfde is.

    Dit probleem doet zich voor sinds El Capitan.

    Bedankt voor de snelle respons,
      Paul
     

    -----------------
    Sandwijk Support
    Gebruikersvriendelijk databeheer
    Gruttoweide 37
    3993 DK HOUTEN
    tel. 06 - 24 52 75 74
    www.sandwijksupport.nl <http://www.sandwijksupport.nl/>
    [email blocked] <mailto:[email blocked]>
    skype: sandwijk

  3. 3 Posted by Paul Sandwijk on 28 Sep, 2017 01:49 PM

    Paul Sandwijk's Avatar

    Sorry, now the international version:

    Yes, I did (of course).
    With some clients the plugin shows, with others (with the same configuration) is doesn't.
    There must be a difference, but I can't figure out what it is.

    This problem occurs since Mac OS El Capitan.

    Paul

    -----------------
    Sandwijk Support
    Gebruikersvriendelijk databeheer
    Gruttoweide 37
    3993 DK HOUTEN
    tel. 06 - 24 52 75 74
    www.sandwijksupport.nl <http://www.sandwijksupport.nl/>
    [email blocked] <mailto:[email blocked]>
    skype: sandwijk

  4. Support Staff 4 Posted by Support on 29 Sep, 2017 07:50 AM

    Support's Avatar

    Dag Paul,

    Geen probleem. Je mag ons ook in het Nederlands schrijven.
    Gebruik je de laatste versie van PrinterSwitch 3? En draait alles onder 64-bit op die computers?

    Met vriendelijke groeten,
    Jasper

  5. 5 Posted by Paul Sandwijk on 29 Sep, 2017 09:00 AM

    Paul Sandwijk's Avatar

    Dag Jasper,

    Met enige schaamte moet ik bekennen dat er iets anders aan de hand was: mijn client was bezig geweest om onderdelen van het runtime-pakket te verplaatsen.
    Nadat ik dit hersteld had, werkte alles weer naar behoren.

    De reden dat ik hier niet onmiddelijk naar gekeken had, was omdat het door mij beschreven probleem tot enige tijd geleden wel degelijk voorkwam, ook op een andere computer (testmachine) die ik beheer en waar zeker niet met de runtime was gerotzooid. Daarbij deed zich ook (tegelijkertijd) het probleem voor dat de runtime-engine het hele databasebestand niet automatisch kon vinden; dat moest je steeds aanwijzen bij opstarten.
    Inmiddels lijken beide problemen nu voorbij te zijn. Op mijn eigen testmachine draait alles nu op rolletjes, net zo soepel als op mijn productie Mac.

    Bedankt voor jullie aandacht.
    Mocht je deze hele conversatie willen verwijderen vanwege het 'loze alarm', dan heb ik daar begrip voor.

    Met vriendelijke groet,
      Paul Sandwijk

  6. Support Staff 6 Posted by Support on 29 Sep, 2017 09:01 AM

    Support's Avatar

    Dag Paul,

    Geen probleem hoor! We zijn blij dat alle problemen van de baan zijn :-)

    Met vriendelijke groeten,
    Jasper

  7. Support closed this discussion on 29 Sep, 2017 09:52 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac