Windows 10 update deactivates PrinterSwitch PDF Driver

david's Avatar

david

05 Jun, 2016 10:59 AM

I have a couple of clients using PrinterSwitch in FM14 runtimes who upgraded their computers to Windows 10. Obviously not the smartest thing to to without making sure that it won't affect existing software, but I'm sure lots of other users have done and will do that, given how hard Microsoft is pushing the upgrade.
Have you/others already encountered this issue?

In any case, after upgrading to Windows 10, the users get an error "Printer not activated, error code -30" - it's the same whether you print using the PrintSwitch plugin or directly using the OS.

I was able to reproduce the issue on a computer of mine that I upgraded to Windows 10. On my computer, PrinterSwitch had been installed using the full installer from your website, but in the runtime distribution, we just include the plugin and the "PrinterSwitch PDF driver" installers.
Still on my computer, I was able to fix the issue by running "Uninstall myFMButler PrinterSwitch" from /Documents/myFMButler/PrinterSwitch.

I don't yet have feedback from my clients on whether running Uninstall.bat and then Install.bat (or Install.exe) is enough to solve the issue. Do you know?
If not, would downloading the full installer from your website and then running that solve the issue?
Or what is the best approach to this issue?

  1. Support Staff 1 Posted by Support on 07 Jun, 2016 07:56 AM

    Support's Avatar

    Hi David,

    I haven't seen this issue yet after an upgrade.
    But indeed, I think your best bet is to run the uninstall batch file and then run the install batch file again.

    Does this issue occur with PrinterSwitch 2.2 or PrinterSwitch 3?

    If you upgrade from PrinterSwitch 2.2 to 3.0, you will also need to reinstall the PDF driver, because we used a newer version for PrinterSwitch 3.0. If you don't upgrade the PDF driver, you will get that message.

    Kind regards,
    Jasper

  2. 2 Posted by david on 07 Jun, 2016 08:02 AM

    david's Avatar

    Hi Jasper,

    Both me and the users that reported this were on PrinterSwitch 3 - I'm not quite sure if any are still using the older 2.2 builds, but I'll let you know if such a case comes up.

    I think it would be a good idea for you to try to reproduce this issue - it's potentially going to affect basically every Windows users, so you may end up spending a lot of time on support for this one...

    /David

  3. 3 Posted by david on 07 Jun, 2016 02:16 PM

    david's Avatar

    Latest feedback from my users indicates that running Uninstall.bat doesn't actually remove the PDF printer, and thus this does not help the issue. You rather seem to have to manually remove the PDF printer using the normal Windows OS functions.

  4. 4 Posted by david on 08 Jun, 2016 07:20 AM

    david's Avatar

    Hi again,

    My users report that they've had to follow these instructions to manually remove the printer driver: https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-manually-uninstall-a-printer-driver-in-Windows.html

    /David

  5. 5 Posted by eric on 06 Sep, 2016 01:06 PM

    eric's Avatar

    Yep, ... I have an issue which seems to be the same.
    The Plug-in is registered, but I get the same Error when trying to use PS. V3 on Windows 10.
    This is with FM15 ADV and/or Runtime.

  6. 6 Posted by david on 06 Sep, 2016 01:14 PM

    david's Avatar

    Hi eric - just to confirm, is this also an upgrade situation, we you had an earlier version of PrinterSwitch installed before? Or did you only upgrade the operating system? Or is it a fresh install of the plugin on Windows 10?

  7. 7 Posted by eric on 06 Sep, 2016 01:20 PM

    eric's Avatar

    Hi David,

    This is also an upgrade.
    And I did have an earlier version of PW installed before.

    In fact it’s a VM with Win 7Pro that has been upgraded to W10.

    I will try a re-install of Win10 on a fresh VM and see what happens.

    Eric

  8. 8 Posted by david on 06 Sep, 2016 01:23 PM

    david's Avatar

    OK, thanks for that info. The safest solution so far in my experience is to download the whole PrinterSwitch plugin installer and run that. That's obviously not a very satisfactory solution - and certainly not in the case of a runtime, which I believe is a very common use for PrinterSwitch.

  9. 9 Posted by eric on 06 Sep, 2016 04:13 PM

    eric's Avatar

    Hi David,

    After quite a bit of tweeking, I finally got PS3 to work on Win10 ( Upgrade )

    Here are my Feedback.

    Uninstall exe from the PI on Win10 does not uninstall all file and packages.
    The printer driver is still present and has to be manually uninstalled Through the Print Server. ( See post from David )

    After removing , re-start and re-install from fresh downloaded PS3
    The Register information, surprisingly where still present and valid at re-start from FMP….. Mmmm. But that’s another story.

    But now, PS3 seems to work correctly both in FM and Runtime.

    Thanks anyway for your help

    Eric

  10. Support Staff 10 Posted by koen on 10 Sep, 2016 07:00 PM

    koen's Avatar

    Hi Eric and David,

    Thank you for the feedback. We will check if we can change our installer to prevent some of the issues you have mentioned.

    Best regards,

    Koen

  11. 11 Posted by david on 12 Sep, 2016 07:57 AM

    david's Avatar

    Thanks Koen - that would be great! Just let me know if you want beta testers for this!

  12. 12 Posted by Steve Wright on 24 Sep, 2016 12:40 PM

    Steve Wright's Avatar

    From my experience, upgrades to windows 10 can cause problems with various printers, not just the amyuni driver (which windows has a habit of updating itself).

    Going to the printer properties > driver section, changing it from Amyuni to anything but its current driver, clicking apply, then changing it back and clicking apply again will usually resolve the issue without the need to uninstall / reinstall anything.

    Why.. I don't know, but that's Windows 10 for you ;)

  13. 13 Posted by david on 23 Jan, 2019 05:50 PM

    david's Avatar

    Any news on this issue? I just had another user report something that sounds very much like the same problem based on the information I have at this point.

  14. 14 Posted by Steve on 23 Jan, 2019 09:25 PM

    Steve's Avatar

    What we do now, which has been very successful is, after installing the PDF driver and it working in FileMaker, we close filemaker, go into the control panel, right click the PDF printer and choose remove.

    Sounds odd, I know.

    On startup during the activation of the licence, it re-creates the pdf printer but also removes it on shut down of filemaker. It has worked for us and our clients successfully since doing that. IMO, its not really myFMButlers issue, its Windows 10 screwing around all the time.

  15. 15 Posted by david on 24 Jan, 2019 07:29 AM

    david's Avatar

    Thanks Steve - that did work. Let's see for how long... Also, this is not something my end users should have to or maybe even are authorized to do, so I'd still love to see some attempt from myFMButler to address this, or, failing that, better documentation of the issue. Or at least somewhat more frequent feedback on this support forum...

  16. Support Staff 16 Posted by Support on 24 Jan, 2019 04:16 PM

    Support's Avatar

    Hi Steve and David,

    Excuse me for not being very active in the the thread.
    I've tried to reproduce a while ago on Windows 10, but I couldn't reproduce it. But out test machines have a clean Windows 10 on them and were not upgrade from Windows 7.
    Did you ever had the issue on a clean Windows 10 machine? Or only on Windows 10 machines that were upgraded from Windows 7?

    Kind regards,
    Jasper

  17. 17 Posted by david on 24 Jan, 2019 04:19 PM

    david's Avatar

    Hi Jasper,

    Great to hear from you!

    I don't always have all the details from all users, but my understand is that this specific to cases where computers have upgraded to Windows 10. I know of upgrades from Windows 8 as well, so it's not just from Windows 7.

    /David

  18. Support Staff 18 Posted by Support on 24 Jan, 2019 04:21 PM

    Support's Avatar

    Hi David,

    Thank you for the feedback. So never on a clean Windows 10?

    And if I understand everything correctly this only happens when using the batch files to install the PDF driver from a runtime, right? Not when you use the normal installer?

    Kind regards,
    Jasper

  19. 19 Posted by Steve Wright on 24 Jan, 2019 04:29 PM

    Steve Wright's Avatar

    It happens on a clean install of windows 10 too, following an update
    (mostly).
    But, as I have said previously, its not only the PDF driver that is
    affected (sometimes anyway) I have personally had lots of device related
    issues following a windows update because it can include driver updates
    including amyuni driver updates. Since it all started appearing (quite
    some time back) I have found the process I mentioned above to be the best
    solution and in 90% of cases, it never re-appeared, but when it did, its
    super simple to just remove the pdf device from control panel to resolve it.

    In my case, I do not use the installer but the batch files to install it.

  20. 20 Posted by Roger Engstrom on 12 Aug, 2019 09:27 AM

    Roger Engstrom's Avatar

    Hi! We've had this issue too.
    In our case it affected upgrades from previous versions that used amuni v4.x where the new runtime uses v5. The problem seems to be that the old driver is not uninstalled before the new one is installed and causes conflicts on Win 8 and 10. Win 7 works fine under the same circumstances it seems.
    Running the uninstall from the v4.5 before installing the latest version did the trick.

    Since that fix got built into our startup scripts we haven't heard from our 2000+ customers on that issue.
    BUT!!! tha last couple of weeks the problem seemed to have come back.

    Of course it was not the same problem, just similar symptoms.
    This time we could see that the printer created a 1-2kb pdf-file instead of 175kb when doing a scripted output to pdf.
    After testing the pdf-printer manually by choosing it in the print dialog it works!
    Both manually in the printer dialog and scripted output.

    Seems the pdf-printer only works after doing a manual print and choosing it first.
    Restarting the runtime resets the problem.

    This is only Windows 10 64-bit machines that I've seen so far.

  21. Support Staff 21 Posted by Support on 20 Aug, 2019 07:32 AM

    Support's Avatar

    Hi Roger,

    Is your runtime solution using the 32-bit version of the FileMaker plugin? We have seen the issue that you're describing on certain Windows 10 machines after installing the Windows July updates.
    We made a new build of PrinterSwitch to be compatible with Amyuni 6, but we're still testing it. If you like to beta it as well, please let me know and I'll send you a copy of the updated plugin and the Amyuni 6 installer.

    Kind regards,
    Jasper

  22. 22 Posted by Roger Engström on 20 Aug, 2019 07:46 AM

    Roger Engström's Avatar

    Hi Jasper!

     
    Yes it is the 32-bit version. We are using both but mostly 32-bit because outlook is 32-bit most om the times.
    We also came to the conclusion that it is one of windows updates.
    It seems to be the KB4507435.

    I would gladly test the beta with amuni 6.

    best regards
    Roger

     Från: Support <[email blocked]>
     Till: <[email blocked]>
     Skickat: 2019-08-20 9:32
     Ämne: Re: Windows 10 update deactivates PrinterSwitch PDF Driver [PrinterSwitch #858]

  23. Support Staff 23 Posted by Support on 20 Aug, 2019 10:17 AM

    Support's Avatar

    Hi Roger,

    I have send the plugin and driver to you via email. Please let me know if it solves your issue.

    Kind regards,
    Jasper

  24. 24 Posted by Steve Wright on 20 Aug, 2019 11:37 AM

    Steve Wright's Avatar

    I too would be interested to test the beta, as a long standing licence holder.
    Having similar issues now relating to the July update: KB4507469

  25. Support Staff 25 Posted by Support on 20 Aug, 2019 11:40 AM

    Support's Avatar

    Hi Steve,

    No problem. I have send you the files and instructions by email.
    Please let me know if it resolves the issue.

    Kind regards,
    Jasper

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Windows10ActivationError.png 22.9 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac