Unregister

Eric Schmidt's Avatar

Eric Schmidt

15 Apr, 2016 06:43 PM

Hi Jasper,

I Have the DEV Version. Registration is saved.
So now I need to Un register the version temporarily.
How do you unregister the Plug-In. ?

Thanks

Eric

  1. Support Staff 1 Posted by Support on 20 Apr, 2016 07:42 AM

    Support's Avatar

    Hi Eric,

    There is no function for that, but I'll ask our developer if there is a workaround.

    Kind regards,
    Jasper

  2. 2 Posted by Eric Schmidt on 20 Apr, 2016 09:11 AM

    Eric Schmidt's Avatar

    Hi Jasper,

    Thanks for the reply.
    Maybe a new switch in the PrSw_Configure Function.

    Thanks.

  3. Support Staff 3 Posted by Support on 24 May, 2016 12:01 PM

    Support's Avatar

    Hi Eric,

    I asked our developer to create a new unregister function.
    While he was looking into it, he came with an other solution.

    Basically you could use the following functions to make your registration invalid.

    mFMb_Configure("register|unregistered")
    mFMb_Configure("save")

    Does this work for you?

    Kind regards,
    Jasper

  4. 4 Posted by Eric SCHMIDT on 28 Mar, 2017 03:38 PM

    Eric SCHMIDT's Avatar

    Hi Jasper,

    Since the last update of FM, I have strange behavior with Printer Switch.
    I cannot get the Plugin to reset correctly PrinterSetup.

    Scenario.
    Défaut is Laser HP M551.
    Switch to Label printer with Adequate print setup using Printerswitch => OK
    Switch back to Laser Princier ( HP M551 ) with default setup. => Does not switch back correctly.
    LaserPrinter does show up correctly in the « Setup page » Menu, but when getting in Preview mode, … it stays on another printer setup ( LabelPrinter )

    I have tested …. a lot. with no luck.
    Didn’t even try to test on Window for now.

    Could you have a look at this ?

    Thanks

    Eric

  5. Support Staff 5 Posted by Support on 29 Mar, 2017 06:42 AM

    Support's Avatar

    Hi Eric,

    I'm sorry to hear this.
    If I understand it correctly, this issue is there since updating to FileMaker Pro 15.0.3?
    Could you also tell me which operating system you're using? And are you using the 32 or 64-bit version of the plugin?

    Kind regards,
    Jasper

  6. 6 Posted by Eric SCHMIDT on 29 Mar, 2017 07:08 AM

    Eric SCHMIDT's Avatar

    Hi Jasper,

    I don’t really know if it’s 32 or 64 bits ( the PI Info doesn’t mention this ) , but i’m using 3.0.9.0 version of the PI which seems to be the latest ( And probably 64 bits ) available version

    I’m using Mac OS X 10.11.6, but also tested with 10.12.

    And yes this is with FM 15.0.3.

    Thanks.

    Eric

  7. Support Staff 7 Posted by Support on 29 Mar, 2017 07:37 AM

    Support's Avatar

    Hi Eric,

    You can run Get(ApplicationArchitecture) to see if you're using the 32 or 64-bit version of FileMaker.

    And which version of FileMaker Pro were you using before the issue occurred? 15.0.1 or 15.0.2?

    Kind regards,
    Jasper

  8. 8 Posted by Eric SCHMIDT on 29 Mar, 2017 07:43 AM

    Eric SCHMIDT's Avatar

    Hi Jasper.

    It’s Filemaker 64 bits.

    And I was Running fm 15.0.1 and / Or 15.0.2 ( on other computer )

    Thanks

    Eric

  9. Support Staff 9 Posted by Support on 29 Mar, 2017 07:57 AM

    Support's Avatar

    Hi Eric,

    Thank you for the information.
    I suspect that there is something changed in FileMaker Pro 15.0.3 which PrinterSwitch doesn't like. We're trying to figure out what changed.

    I'll keep you updated on this.

    Kind regards,
    Jasper

  10. 10 Posted by Eric SCHMIDT on 29 Mar, 2017 08:49 AM

    Eric SCHMIDT's Avatar

    Hi Jasper,

    OK, the PI just doesn’t work on print Setup anymore with Filemaker or is erratic.

    Screen_1 : Browse mode.

    Screen_2 : Preview mode

    Screen_3 : PrintSetup
    As you can see, Laser is selected, ( Running a script calling the Plugin ) but has no effect in Filemaker as the Layout still keeps the LabelWriter setup.
    Only if I click on « OK » THEN, the setup is refreshing in FileMaker.
    If I Click « Cancel » the Label PrintSetup stays as the valid Printsetup even if in the Setup menu it says Laser setup is active.

    Scree_4

    After a click on OK, … the Print Setup is Laser, … as desired.

    Hope this will put you on the right Track.

    Eric

  11. 11 Posted by Eric Schmidt on 14 Jun, 2017 04:55 PM

    Eric Schmidt's Avatar

    Hi Jasper,

    Any News ?

  12. Support Staff 12 Posted by Support on 19 Jun, 2017 08:00 AM

    Support's Avatar

    Hi Eric,

    We're not able to reproduce this issue. We have also tried FMP 16, but we can't reproduce it.
    What happens if you try the same setup in FileMaker Pro 16?

    Kind regards,
    Jasper

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac