Printerswitch PDF driver wo'nt install on Windows7 Filemaker 11

Louk Burggraaf's Avatar

Louk Burggraaf

17 May, 2010 08:26 AM

Printerswitch PDF driver wont install on Windows7 64bits / Filemaker 11. Even when mannually trying to install through the install64.bat (tried also install as admin) the driver is not installed...

  1. 1 Posted by Louk Burggraaf on 17 May, 2010 09:33 AM

    Louk Burggraaf's Avatar

    Part of the problem solved. Installed the driver (placed the driver directory on the local disk it was not). The driver is installed but when using the demo for creating PDF I get 'Printer not activated, error code -41' What can be wrong?

  2. 2 Posted by Louk Burggraaf on 17 May, 2010 09:39 AM

    Louk Burggraaf's Avatar

    Restarted the pdf demo and now I get 'Printer not activated, error code -20' No idea what is wrong....

  3. Support Staff 3 Posted by Support on 17 May, 2010 07:38 PM

    Support's Avatar

    Hi,

    We seem to be unable to reproduce the problem. In order to try and determine the cause, please try to see whether you can reproduce the issue running the standard PrinterSwitch installer, and using the PDF example.

  4. 4 Posted by Louk Burggraaf on 18 May, 2010 06:58 AM

    Louk Burggraaf's Avatar

    We did... we can arrange a terminal session so you can see it...

  5. Support Staff 5 Posted by Support on 18 May, 2010 12:08 PM

    Support's Avatar

    The error message you get is a message from the PrinterSwitch PDF driver, which is a driver by Amyuni that we bundle with our plug-in.

    It looks like this is a privileges problem - I did find the following information on the Amyuni forum, however, (http://www.amyuni.com/forum/) when referring to the 'printer not activated' problem:

    All users of the PDF Converter must have at least read/write privileges to the "HKEY_CURRENT_CONFIG\Software" and "HKEY_CURRENT_CONFIG\Software" keys in the registry.

    and

    "if you have a non-english version of Vista, you have to add permissions in the registry on the following hive : HKEY_CURRENT_CONFIG\Software Give full control to "users"."

    Can you check whether this might be causing the issue ?

  6. 6 Posted by Louk Burggraaf on 19 May, 2010 08:32 AM

    Louk Burggraaf's Avatar

    Yes, this solved the issue. The demo now works. Why isn't it a default registry setting? Guess not everyone has an English Vista of W7 version...
    Also installing didn't get right the first time. In installed the nul: port but it another driver was attached (not the Ayumi). Changed this by hand.

  7. Support Staff 7 Posted by Support on 19 May, 2010 02:22 PM

    Support's Avatar

    We have reported the issue to Amyuni, and asked if there was going to be an easier workaround /solution.

    When they send us an update, we'll keep you informed.

  8. Support closed this discussion on 19 May, 2010 02:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac