AutoSender 2.5 quirk

Ian's Avatar

Ian

03 Apr, 2018 07:01 PM

I don't have much hope here since it's such an old version, but after rebooting a Mac Mini (OS X Server 10.6.8) that AutoSender 2.5 is running on, it no longer marks the record as "sent" (does not change the "status" field to 1), and keeps re-sending. Nothing changed in the configuration; it was just a machine reboot.
None of the issues in this article apply: http://support.myfmbutler.com/kb/autosender/resending
If you can offer any advice, I'd be very appreciative!

  1. Support Staff 1 Posted by Support on 04 Apr, 2018 06:50 AM

    Support's Avatar

    Hi Ian,

    That's a very rare issue. There a few things that I can think of now:
    - Record locking - Corrupt database - AutoSender account has no write access anymore

    The easiest way to debug this, would be by uploading the AutoSender sample file to your server and try to send an email from the sample database.
    If the mail gets send correctly from the sample database, then there is probably something going on with your database. If the same problem occurs, something happend to the AutoSender application.

    Please let me know the outcome from this test.

    Kind regards,
    Jasper

  2. 2 Posted by Ian on 04 Apr, 2018 07:49 PM

    Ian's Avatar

    Hi Jasper,
    I dug out the original MailExample_xml.fp7 file and put it on the server. Same result - the mail gets sent, but the Status field doesn't get changed. If I open it with the same user/password defined in the "Source," I can edit fields, so the account has write access.
    If there's a 2.5 installer I can download, I'll be glad to try reinstalling it.
    Thanks for your help!
    Ian

  3. Support Staff 3 Posted by Support on 05 Apr, 2018 06:53 AM

    Support's Avatar

    Hi Ian,

    Ok, that means the problem is FileMaker Server or AutoSender.
    Attached you can find the 2.5 installer.

    Let me know if reinstalling AutoSender fixes the problem.

    Kind regards,
    Jasper

  4. 4 Posted by Ian on 05 Apr, 2018 04:36 PM

    Ian's Avatar

    I stopped the daemon and removed the relevant files from /Applications, /Library/Application Support, & /Library/LaunchDaemons, but the installer failed with the message "The installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance." There was no further info that I could find in the console logs.
    I'll try reinstalling after a reboot (I have to wait until after hours, since it's on a production machine).

  5. Support Staff 5 Posted by Support on 06 Apr, 2018 08:54 AM

    Support's Avatar

    Hi Ian,

    Thank you for the update.
    Please let me know how it goes after the reboot.

    Kind regards,
    Jasper

  6. 6 Posted by Ian on 07 Apr, 2018 06:03 PM

    Ian's Avatar

    I stopped the daemon, moved the relevant files to the desktop, rebooted, and ran the installer. Got the "installation failed" error. No additional info in the console logs.

    I moved all the files back to their original locations, launched the AutoSender Config app, and got a "could not start daemon" error. Rebooted, and still got the same error.

    Looking at the .plist in /Library/LaunchDaemons, I saw it opens /Library/Application Support/myFMbutler/myFMbutler AutoSender.app/Contents/MacOS/AutoSender at startup, so I manually launched that. AutoSender Config indicated it was running.

    I created a test email in my production file, and everything worked fine. AutoSender sent the email and correctly marked it as sent.

    So everything works, but I really can't tell you why :)

    Thanks a bunch for your help and quick replies - I really appreciate it!

  7. Support Staff 7 Posted by Support on 09 Apr, 2018 10:12 AM

    Support's Avatar

    Hi Ian,

    That is really a strange issue, but I'm glad you found a solution to make it work again.
    Thank you for your feedback!

    Kind regards,
    Jasper

  8. Support closed this discussion on 09 Apr, 2018 10:12 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac