Error-Message XML can't be edited

herbst's Avatar

herbst

13 Jul, 2016 09:38 AM

Hi,

I've got the following problem: in former versions of Clip Manager I was able to change the storage options, especially setting global storage to true, when the clipboard contained fields. This is extremely helpful when setting up working tables with fields with global storage as representations for user input in dialogs. This just happenend today in a situation where I had to turn storage to global for some 40 fields manually.

Can the behaviour be turned back to the former one. Maybe it would be an opportunity to get a warning message before doing this kind of edting.

Best regards
Holger

  1. Support Staff 1 Posted by Support on 15 Jul, 2016 10:11 AM

    Support's Avatar

    Hi Holger,

    Did you do the find and replace in the source or xml view? The behaviour could be different.

    And can you specify with search and replace you did?

    If you do a find and replace and the XML is invalid, then we show an error. And this XML file won't past in FileMaker Pro.

    Kind regards,
    Jasper

  2. 2 Posted by herbst on 15 Jul, 2016 11:27 AM

    herbst's Avatar

    Hi Jasper,

    I’ve made a screenshot, that should explain my problem. The shown action was possible in V4.

    Best regards
    Holger

  3. Support Staff 3 Posted by Support on 15 Jul, 2016 03:05 PM

    Support's Avatar

    Hi Holger,

    If you look a the replace field, you'll see that the quotes are different. This will make the XML invalid. You need to use "normal" quotes.

    I think you can fix it by changing the smart quotes option. I attached a screenshot of the setting on my system and I don't have this problem in ClipManager.
    And if that doesn't work, could try again with smart quotes off?

    Could you try this?

    Kind regards,
    Jasper

  4. 4 Posted by herbst on 20 Jul, 2016 06:07 AM

    herbst's Avatar

    Hi Jasper,

    thank you for your help. Changing the keyboard/text settings in OS X did the trick.

    best regards
    Holger

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac